10th May 2021

(SG) Singapore Perth - Singapore (ASC) Incident

GSL operations monitoring has picked up a failure event between Perth and Singapore via the Australia Singapore Cable.

We have reached out to the upstream partner and will provide updates as they become available.

Update 1: 4:00PM AEST

We have seen the link restore.

We are waiting for confirmation and updates from the upstream vendor.

Update 2: 5:00PM AEST

Our upstream has replaced the faulty plug unit. All affected services are marked as restored.